Am I missing creatures?

Percula1869
Percula1869

On 06/26/2015 at 09:32 Quote this message

The only creatures I can see in the aquatic market place are all the ones that I have,which go up to psephoderma. I know there are more but they don't show up even as DNA not found yet. Then when I just clicked on the get hybodus it doesn't show up either while the nasutoceratops did on the Jurassic side. Is it just because I'm only level 28 or do I have a bug of some kind? I've also been having a ton of problems loading the parks. It gets to sending critical messages, sits there for a while, and then says connection lost. I have to try 10-15 times. I hope it's not something to do with that. Thanks for any help.

On 06/26/2015 at 12:51 Quote this message

For some creatures you have to be at a certian level before your able to get them. Hybodus requires level 55 or higher before it'll be available in your market. Other "normal" creatures will continue unlock as you progress through the game. You'll find their DNA eventually if you keep sending out expeditions as you level up.

As for your loading issues, is your internet connection strong? If it cuts out while the game is loading it'll get hung up and doesn't finish loading. If you do have a strong connection my only other thought is to ask Ludia support about it, see if they have a solution for you.

Hope that helps
Percula1869
Percula1869

On 06/26/2015 at 14:27 Quote this message

It happens on both wifi and LTE and the connection is strong on both. I even tried playing on PC through Facebook and it did they same thing. I emailed ludia about it, I guess we'll see what happens.

On 06/29/2015 at 12:27 Quote this message

Hopefully your game save file isn't found to be corrupted or something like that. Let us know what they say
Percula1869
Percula1869

On 06/30/2015 at 01:05 Quote this message

Well they never sent a reply, but a few days after sending the email I could magically log in fine again so I'm guessing they fixed it.

On 07/01/2015 at 19:28 Quote this message

You'll probably get a reply from them soon. I contacted support recently because the Jurassic World game keeps crashing on me. It took them 11 days to respond so they must be pretty busy. At least everything started workin for ya

Post a reply

You're using an AdBlock like software. Disable it to allow submit.