Whats your white whale?

On 02/28/2015 at 23:39 Quote this message

Anyone else have a dino they cant seem to get no matter how much they try? Mines the Sea Scorpion. Next time Im just paying the 359 for it.

On 03/01/2015 at 11:30 Quote this message

protosphyraena and gigantopithicus

On 03/01/2015 at 23:41 Quote this message

They dont release the protosphyraena often
Overthrown
Overthrown

On 03/02/2015 at 02:55 Quote this message

I am pretty new to the game still (started playing three weeks ago) and I think I already got a decent set up of creatures (T-Rex, Stegosaurus, Brontosaurus, Rajasaurus and Pteranodon, and of course some other coin dinosaurs). At least in Terms of the jurassic park.

But what I really wish to have in my park is the Mosasaurus!
Unfortunately there is no opportunity in sight....

On 03/06/2015 at 02:13 Quote this message

Megalodon and mosasaurus. It seems I'm always low on bucks when they get released
Caio
Caio

On 03/16/2015 at 16:46 Quote this message

I've got all dinos in Jurassic and Aquatic parks, except a few I've missed from DNA rescue. But I haven't got some specials from the Glacier park yet, like the Dodo and the Smilodon. In total, I'm missing 3 Jurassic, 5 aquatic and 7 glacier, mostly the DNA rescue ones and including the ones that haven't been released yet.

On 03/20/2015 at 02:13 Quote this message

I have one from each park that I never have the bucks for when they come around. I really wish I could make the 120 buscks tourny, its very bad timing for me

On 03/25/2015 at 09:57 Quote this message

FINALLY got protosphyaena today. Puts me at 100% of all available creatures... No more white whale for me!
Caio
Caio

On 05/04/2015 at 17:45 Quote this message

I had all "old" creatures, but I am having a really hard time getting some of the new ones. The last three that showed up that I still didn't have (still don't, actually), the Koolasuchus, the Coryphodon (I thought those 2 were DNA rescue creatures, from the time I wasn't playing those, but it seems they're not after all) and most recently the Andrewsarchus, I sent many 5 bucks expeditions all weekend but didn't get a SINGLE one of them.

Seems like Ludia is getting real greedy, trying to get back our dino bucks (I never paid them real money, only got my bucks from playing tournys, completing missions etc.).

The worst thing is that I didn't even get the chance to pay the 359 bucks for them. They simply never showed up (yes, if they did I wouldn't have paid 360 as I was sending 5 buck expeditions, but anyway).

I actually got the Andrewsarchus with my Guest profile (which is already about level 48 - my Facebook profile is level 95). But I would rather have this (and the others) in my Facebook profile first...

On 05/04/2015 at 18:01 Quote this message

@Caio; Make sure you rush the missions back home. Pay 5 bucks to send 3 containers and 9 bucks to get them back instantly. Repeat that until you get the DNA.

I usually only have to spend around 150 bucks by sending and rushing missions back home in order to get an expedition dino. Occasionally I've had to spend close to 300, but that hasn't happened very often and is offset by the couple of times that I've spent less than 50.

If play in the 120 dino buck tournaments in each park, it really only takes 1 day to pay for an expedition dino.

On 05/04/2015 at 19:01 Quote this message

The Mastodon cost me over 1000 dino bucks before an expedition finally returned with its DNA. Other than that it averaged around 150 bucks, same as Pon_Farr
Caio
Caio

On 05/11/2015 at 17:47 Quote this message

I've tried, for those 3 dinos, after trying to get them all weekend long (without rushing expeditions), on Sunday night or Monday morning (when they were still available), I've tried to rush a few expeditions to see if I would get lucky. I tried rushing about maybe 4 extra expeditions for each of them (costing me 56 bucks), not to mention the previous ones (not rushed), which adds up to about 10 or 12 expeditions in each case, and no success. So I didn't want to spend even more bucks and risk still not getting them after spending 1,000 bucks like buildersaurus_rex's Mastodon... But it is really frustrating.

Next time they come around, I think I will just send the free expeditions, then I'm pretty sure they will show up in the capsules I didn't buy, and them I can get them for 359 bucks.....

On 05/11/2015 at 18:53 Quote this message

Its worth mentioning that out of 25+ limited edition creatures obtained through expedition, the Mastodon is the one and only time I have spent more than 300 bucks on expeditions. Every other creature I obtained (and I have now them all) after spending less than 300 bucks before an expedition returned with DNA. Furthermore, the Mastodon was something I was very determined to get. Its eluded me in the past and does't come around too often.

On 05/12/2015 at 03:11 Quote this message

Sea Scorpion was the one that eluded me the most. I am fully stocked!

Sea Scorpion also has by far the best special attack IMHO
Zimo Yang
Zimo Yang

On 11/30/2015 at 08:36 Quote this message

I'm just a starter and played 3 weeks in the aquatic park but still just have the dunkleosteus! I want to know why ! My expeditions are almost always the 5-bucks-expedition but I don't get any DNA! Why is my luck always so bad in that game???

On 11/30/2015 at 10:28 Quote this message

Are you clearing land like you did in the main park? You'll never find DNA on expedition unless your clearing land as well. On a side note, I wouldn't send out all 3 expeditions unless your after a limited edition creatures that has been released. Otherwise its just a waste of dino bucks
Zimo Yang
Zimo Yang

On 12/02/2015 at 21:22 Quote this message

Hmmm... maybe your not far enough in the land missions to unlock the aquatic stuff. Thats my only other thought. If all else fails, just send a email to support and ask them. Sorry I couldn't be of more help
Zimo Yang
Zimo Yang

On 12/15/2015 at 09:05 Quote this message

after all, I got ammonite and kronosaurus!

On 12/16/2015 at 01:18 Quote this message

Nice, did you just need to progress further in the story to get them or clear more land?

Post a reply

You're using an AdBlock like software. Disable it to allow submit.